Managecast is now a proud member of the VEEAM Cloud Connect Partner Program

 

VCSP_silver_logo

Managecast is a featured partner on VEEAM’s list of service providers that offer the VEEAM Cloud Connect services. VEEAM Cloud Connect enables you to quickly and efficiently get your VEEAM backups offsite, safe and secure, so you can always recover your data no matter what!

Our services powered by VEEAM allow for:

  • Full integration with VEEAM
  • Secure, encrypted backup, replication, and restore
  • Full-site failover
  • Full and partial failback
  • Quick site failover testing
  • Fast recovery

Managecast is offering 30 day, no-oligation, free trials and enabling your existing VEEAM installation could not be easier. Get your existing VEEAM backups offsite using the familiar VEEAM management console. Managecast can also provide updated VEEAM software and licensing if required.

Our Cloud-based disaster recovery and offsite backup powered by VEEAM can now be easily used to provide offsite disaster recovery capabilities for your organization. Contact us for a free trial.

image001managecast-Logo1-small

Veeam v 8 Certificate Error When Upgrading (Authentication failed because the remote party has closed the stream)

We were setting up Veeam cloud connect infrastructure in order to provide Veeam Cloud Backup – which many of our customers were asking us to provide. Everything was going well with the installation and we started out with a self signed certificate for testing.  We then applied a certificate from a well-known Certificate Authority and it still worked fine.  We then got a notifacation from Veeam about an available update (v8 Update 3).  It is import to be on the same version or higher as clients so we went to update right away.

Upon updating to Update 3, Clients could no longer connect, getting the following error when trying to connect:

“Error: Authentication failed because the remote party has closed the stream”

This was happening immediatly when connecting and Veeam wouldnt let editing the Cloud repository continue because it did not have a certificate.

First, we tried reapplying the certificate on the service provider side. Although it completed successfully, the clients were still getting the same error.

We then tried just creating a new Self-signed certificate and that didnt work.

We thought maybe the client had to be on the same version, So I upgraded a client to version 3 and still got the same error.

Before updating Veeam, we had taken snapshots of all the Veeam components (Backup and Replication server, Cloud Gateway, WAN Accelerator, and Repository).  We reverted to before the upgrade and the clients could connect whether it was a self-signed certificate or from the Certificate Authority.

There were previous updates available, so we tried with Update 2 as well. Same results.

At this point, we opened a support ticket with Veeam. We uploaded Logs from every component and from the client side.  After they inspected the logs they came back and had us try installing update 2b, sending them logs from before and after the upgrade.  We still had the same results!

After they inspected those logs they sent me a process to try that ultimately worked.

They had us first apply a Self-Signed Certificate on the base installation of Version 8 and then upgrade to 2b, and if the self signed certificate still worked, to then apply the one from the Certificate Authority from the pfx file.

It worked!

We still had Update 3 to get to so I took another set of snapshots and upgraded to Update 3 and everything stayed working.

Hopefully this can save you some time, As I didn’t see this error documented in Veeam’s KB articles or documentation about installing certificates.